Show Changes Show Changes
Edit Edit
Print Print
Recent Changes Recent Changes
Subscriptions Subscriptions
Lost and Found Lost and Found
Find References Find References
Rename Rename
Administration Page Administration Page
Topic Locks Topic Locks

Search

History

12/14/2014 11:33:20 PM
-122.102.45.251
12/2/2014 8:13:57 PM
-181.41.219.37
11/6/2014 9:57:08 PM
-122.102.45.251
10/16/2014 11:49:21 PM
-180.178.111.102
8/17/2014 10:47:57 PM
-180.178.111.105
List all versions List all versions

RSS feed for the SquirrelWiki namespace

SQDEV
.
                        Summary: an IBM eclipse plugin for squirrel development

To find out what we can do for you, contact us today. We are available to talk to you via phone or the form in our Contact section. Our team aims to please as we offer a website that is everything that you require at prices that will not break your budget. Our friendly, experienced staff members are on hand and waiting to start creating and designing your online presence today.

melbourne web designer

Melbourne SEO Services

Elcometer 456

Online Magazine

Features

Installation

Requirements

SQDev requires the following to install and run:

  1. A Java JRE (or SDK) 1.5 or greater. You can get Java here:
  2. Eclipse SDK 3.2 or greater. You can get Eclipse here:

Installing SQDev

  1. In Eclipse, select Help => Software Update => Find and Install...
  2. Select "Search for new features to install"
  3. Select "New Remote Site" and enter the following: Name: SQDev Update Site,
  4. Make sure the new update site is checked. (Note: You might need to uncheck "Ignore features not applicable to this environment" to make it work)
  5. Click "Finish" and follow the prompts.
  6. When finished, please restart the workbench when asked.
  7. (Optional) Enable Syntax Checking (disabled by default), see below.

Upgrading SQDev (Once installed)

  1. In Eclipse, select Help => Software Update => Find and Install...
  2. Select "Search for updates of the currently installed features."
  3. If updates are found, it will prompt to install them.
Note

Create a project

Note
Note

Squirrel perspective

To enable the squirrel perspective form the main eclipse menu Window/Open Perspective/Others select Squirrel

Automatic syntax checking

SQDev has two forms of syntax checking. One is internal to SQDev and attempts to identify common structure errors. The other is by executing an external Squirrel binary and capturing any errors it detects. Using both is recommended, as there are currently some errors only detected in one or the other (but both make your code better!).

SQDev's editor supports automatic syntax checking.

Every time a '.nut file is saved sqdev will invoke sq.exe and compile the file.

  1. If any syntax error is present, an icon will be placed at the line that caused the error.
  2. a marker is also added in eclipse's Problems view(Window/Show View/Other/ + Basic/Problems)

To enable (external) automatic syntax checking.

Debugger

To debug your project.

Target Address

IP address of the application(disables if localhost)

Port

IP port of the application

Localhost

if true the debugger ignores the IP Address and always connect to the local machine

Autorun Interpreter

if checked the debugger will run the executable specified in Interpreter

Interpreter

the application that has to be debugged

Working Directory

working directory of the application

Command Line Options

command line parameters passed to the application at startup

Suspend on startup

suspends the application on the first squirrel line that gets executed

Default debugger setting

It is possible to set defaults for you debugger configuration.

How to use the debugger

Launch

Launch you application by pressing the debug button in the toolbar(the one with the green bug icon)

Switch to debug perspective, by pressing the debug button on the perspective toolbar(number 1 in the image)

Call stack

You can navigate the call stack by selecting a function in the Debug View(number 2 in the image)

Breakpoints

To add a breakpoint double click on the gray left border of the editor(see number 4 in the image)

To remove it, double click again on the breakpoint icon

To jump on a breakpoint select the breakpoint in the breakpoint view(see number 5 in the image)

Errors

The debugger will automatically jump to the file location if a unhandled exception occurs

Variables

Call stack's variables are displayed in the variable view(number 3 in the image)

Watches

Left click on the Expression view and select "Add Squirrel Watch Expression"(number 6 in the image)

The expression will be evaluated on a breakpoint or on the next step

Stepping

After the application has been suspended by a breakpoint or by pressing the pause button in the debug view(number 2 in the image):

Note that you must be in debug perspective

Terminate the application

You can terminate the application by pressing the stop button in the debug view(number 2 in the image)

Suspend the application

You can suspend the application by pressing the suspend button in the debug view(number 2 in the image)

Not logged in. Log in

squirrel's community wiki

This is FlexWiki, an open source wiki engine.

Change Style

Recent Topics